Vvmebel.com

Новости с мира ПК
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Как работает формула если в excel

Функция IF (ЕСЛИ) в Excel. Как использовать?

Функция IF (ЕСЛИ) в Excel – это отличный инструмент для проверки условий на ИСТИНУ или ЛОЖЬ. Если значения ваших расчетов равны заданным параметрам функции как ИСТИНА, то она возвращает одно значение, если ЛОЖЬ, то другое.

Что возвращает функция

Заданное вами значение при выполнении двух условий ИСТИНА или ЛОЖЬ.

Синтаксис

=IF(logical_test, [value_if_true], [value_if_false]) – английская версия

=ЕСЛИ(лог_выражение; [значение_если_истина]; [значение_если_ложь]) – русская версия

Аргументы функции

  • logical_test (лог_выражение) – это условие, которое вы хотите протестировать. Этот аргумент функции должен быть логичным и определяемым как ЛОЖЬ или ИСТИНА. Аргументом может быть как статичное значение, так и результат функции, вычисления;
  • [value_if_true] ([значение_если_истина]) – (не обязательно) – это то значение, которое возвращает функция. Оно будет отображено в случае, если значение которое вы тестируете соответствует условию ИСТИНА;
  • [value_if_false] ([значение_если_ложь]) – (не обязательно) – это то значение, которое возвращает функция. Оно будет отображено в случае, если условие, которое вы тестируете соответствует условию ЛОЖЬ.

Дополнительная информация

  • В функции IF (ЕСЛИ) может быть протестировано 64 условий за один раз;
  • Если какой-либо из аргументов функции является массивом – оценивается каждый элемент массива;
  • Если вы не укажете условие аргумента FALSE (ЛОЖЬ) value_if_false (значение_если_ложь) в функции, т.е. после аргумента value_if_true (значение_если_истина) есть только запятая (точка с запятой), функция вернет значение “0”, если результат вычисления функции будет равен FALSE (ЛОЖЬ).
    На примере ниже, формула =IF(A1> 20,”Разрешить”) или =ЕСЛИ(A1>20;”Разрешить”) , где value_if_false (значение_если_ложь) не указано, однако аргумент value_if_true (значение_если_истина) по-прежнему следует через запятую. Функция вернет “0” всякий раз, когда проверяемое условие не будет соответствовать условиям TRUE (ИСТИНА).

|

  • Если вы не укажете условие аргумента TRUE(ИСТИНА) (value_if_true (значение_если_истина)) в функции, т.е. условие указано только для аргумента value_if_false (значение_если_ложь), то формула вернет значение “0”, если результат вычисления функции будет равен TRUE (ИСТИНА);
    На примере ниже формула равна = IF (A1>20;«Отказать») или =ЕСЛИ(A1>20;”Отказать”) , где аргумент value_if_true (значение_если_истина) не указан, формула будет возвращать “0” всякий раз, когда условие соответствует TRUE (ИСТИНА).
  • Функция Если в Excel примеры с несколькими условиями

    Пример 1. Проверяем простое числовое условие с помощью функции IF (ЕСЛИ)

    При использовании функции IF (ЕСЛИ) в Excel, вы можете использовать различные операторы для проверки состояния. Вот список операторов, которые вы можете использовать:

    Ниже приведен простой пример использования функции при расчете оценок студентов. Если сумма баллов больше или равна “35”, то формула возвращает “Сдал”, иначе возвращается “Не сдал”.

    Пример 2. Использование вложенной функции IF (ЕСЛИ) для проверки условия выражения

    Функция может принимать до 64 условий одновременно. Несмотря на то, что создавать длинные вложенные функции нецелесообразно, то в редких случаях вы можете создать формулу, которая множество условий последовательно.

    В приведенном ниже примере мы проверяем два условия.

    • Первое условие проверяет, сумму баллов не меньше ли она чем 35 баллов. Если это ИСТИНА, то функция вернет “Не сдал”;
    • В случае, если первое условие – ЛОЖЬ, и сумма баллов больше 35, то функция проверяет второе условие. В случае если сумма баллов больше или равна 75. Если это правда, то функция возвращает значение “Отлично”, в других случаях функция возвращает “Сдал”.

    Пример 3. Вычисляем сумму комиссии с продаж с помощью функции IF (ЕСЛИ) в Excel

    Функция позволяет выполнять вычисления с числами. Хороший пример использования – расчет комиссии продаж для торгового представителя.

    В приведенном ниже примере, торговый представитель по продажам:

    • не получает комиссионных, если объем продаж меньше 50 тыс;
    • получает комиссию в размере 2%, если продажи между 50-100 тыс
    • получает 4% комиссионных, если объем продаж превышает 100 тыс.

    Рассчитать размер комиссионных для торгового агента можно по следующей формуле:

    В формуле, использованной в примере выше, вычисление суммы комиссионных выполняется в самой функции ЕСЛИ . Если объем продаж находится между 50-100K, то формула возвращает B2 * 2%, что составляет 2% комиссии в зависимости от объема продажи.

    Пример 4. Используем логические операторы (AND/OR) (И/ИЛИ) в функции IF (ЕСЛИ) в Excel

    Вы можете использовать логические операторы (AND/OR) (И/ИЛИ) внутри функции для одновременного тестирования нескольких условий.

    Например, предположим, что вы должны выбрать студентов для стипендий, основываясь на оценках и посещаемости. В приведенном ниже примере учащийся имеет право на участие только в том случае, если он набрал более 80 баллов и имеет посещаемость более 80%.

    Вы можете использовать функцию AND (И) вместе с функцией IF (ЕСЛИ) , чтобы сначала проверить, выполняются ли оба эти условия или нет. Если условия соблюдены, функция возвращает “Имеет право”, в противном случае она возвращает “Не имеет право”.

    Формула для этого расчета:

    =IF(AND(B2>80,C2>80%),”Да”,”Нет”) – английская версия

    =ЕСЛИ(И(B2>80;C2>80%);”Да”;”Нет”) – русская версия

    Пример 5. Преобразуем ошибки в значения “0” с помощью функции IF (ЕСЛИ)

    С помощью этой функции вы также можете убирать ячейки содержащие ошибки. Вы можете преобразовать значения ошибок в пробелы или нули или любое другое значение.

    Формула для преобразования ошибок в ячейках следующая:

    =IF(ISERROR(A1),0,A1) – английская версия

    =ЕСЛИ(ЕОШИБКА(A1);0;A1) – русская версия

    Формула возвращает “0”, в случае если в ячейке есть ошибка, иначе она возвращает значение ячейки.

    ПРИМЕЧАНИЕ. Если вы используете Excel 2007 или версии после него, вы также можете использовать функцию IFERROR для этого.

    Точно так же вы можете обрабатывать пустые ячейки. В случае пустых ячеек используйте функцию ISBLANK, на примере ниже:

    =IF(ISBLANK(A1),0,A1) – английская версия

    =ЕСЛИ(ЕПУСТО(A1);0;A1) – русская версия

    Формула в Эксель ЕСЛИ, когда несколько условий

    Эксель — отличный редактор, позволяющий решать множество задач быстро и просто. Здесь легко посчитать проценты, провести корреляционный анализ, построить графики и т.д. Функционал программы огромен, поэтому далеко не все сразу понимают, каким оператором нужно воспользоваться, чтобы справиться с конкретной проблемой. Рассмотрим на примерах, как работать с формулой ЕСЛИ с несколькими условиями.

    Функция ЕСЛИ

    Написать формулу в Excel можно двумя способами — вручную, введя данные в строку функции или прямо в ячейку, и обратившись к меню. Попробуем разобраться, как пользоваться функцией ЕСЛИ на примере. Алгоритм действий довольно простой — указывается определенное условие и варианты, что следует делать в случае истины или лжи (то есть условие либо выполняется, либо нет):

    • Открываем Эксель, найдя программу в меню «Пуск» или на рабочем столе.

    • Вводим данные, с которыми предстоит работать. Допустим, есть информация о сотрудниках компании — ее и будем использовать в качестве материала.
    Читать еще:  Обновить word 2003

    • Добавляем столбец «Премия» — в него выводим результаты функции ЕСЛИ. Курсор ставим в ячейку G4.

    • Кликаем по значку функции, расположенному слева от строки ввода оператора, которая находится над рабочим полем. Также формулу в Эксель можно вставить, обратившись к пункту меню «Формулы» и выбрав там «Логические».

    • В «Категории» находим «Логические», а в появившемся списке — функцию ЕСЛИ. Кликаем по «Ок».

    • Появится окно, где необходимо указать аргументы функции, то есть условия.

    • Предположим, премия менеджеров составляет 30%. Заполняем аргументы, начиная с логического выражения — пишем там адрес ячейки и нужное значение. В нашем случае это выглядит следующим образом: Лог_выражение = D4=«менеджер». Затем указываем размер премии (30), если выражение истинно, и 0, если оно ложно. Нажимаем «Ок».

    • В результате видим, что премия первого сотрудника составляет 0%, так как он не является менеджером. Условие выполнено!

    • Таблица содержит множество строк, необходимо заполнить их все. Конечно, не требуется каждый раз вбивать функцию заново, ее надо просто скопировать. Сделать это очень просто — кликаем мышкой по ячейке G4 (там уже получен результат), подводим курсор к левому нижнему углу и смотрим, когда он превратится в плюс.

    • Растягиваем формулу на остальные ячейки, держа левую кнопку мыши нажатой и опускаясь вниз.

    Вот и все — менеджеры получают премию. Воспользовавшись формулой ЕСЛИ, можно быстро сделать выборку нужных сотрудников.

    Важно: конечно, посмотрев на пример, кажется, что и вручную несложно совершить подобные действия, однако все зависит от объема информации — чем больше данных в таблице, тем сложнее их анализировать визуально. Риск упустить что-то слишком велик, а Excel не только сэкономит время, но и поможет избежать ошибок.

    Функция ЕСЛИ с условием И

    Часто одним условием дело не ограничивается — например, нужно начислить премию только менеджерам, которые работают в Южном филиале компании. Действуем следующим образом:

    • Выделяем мышкой первую ячейку (G4) в столбце с премиями. Кликаем по значку Fx, находящемуся слева от строки ввода формул.

    • Появится окно с уже заполненными аргументами функции.

    • Изменяем логическое выражение, добавив туда еще одно условие и объединив их с помощью оператора И (условия берем в скобки). В нашем случае получится: Лог_выражение = И(D4=«менеджер»;E4=«Южный»). Нажимаем «Ок».

    • Растягиваем формулу на все ячейки, выделив первую и потянув мышкой вниз при нажатой левой клавише.

    Совет: если в таблице много строк, то становится неудобно постоянно перематывать вверх-вниз, чтобы посмотреть шапку. Выход есть — закрепить строку в Excel. Тогда названия столбцов будут всегда показаны на экране.

    Функция ЕСЛИ с условием ИЛИ

    В качестве примера рассмотрим, как начислить в Экселе премию в размере 40% всем сотрудникам, которые являются бухгалтерами или директорами. То есть произведем выборку по двум условиям:

    • Кликаем мышью по первой ячейке в столбце премий (G4), затем нажимаем на иконку слева от строки ввода формул.

    • Редактируем аргументы функции. Логическое выражение будет представлять собой: ИЛИ(D4=«бухгалтер»;D4=«директор»). В «Значение_если_истина» пишем 40, а в «Значение_если_ложь» — 0. Кликаем «Ок».

    • Копируем формулу, растягивая ее на остальные ячейки. Смотрим результат — премия 40% начислена директору и двум бухгалтерам.

    Функция СУММЕСЛИ

    Данная формула в Экселе применяется, когда требуется суммировать значения в ячейках, попадающих под какое-либо заданное условие. Например, нужно выяснить суммарную заработную плату всех продавцов:

    • Добавляем строку с общей зарплатой продавцов и кликаем по ячейке, куда будет выводится результат.

    • Нажимаем на иконку Fx, которая находится слева от строки ввода функций. В открывшемся окне ищем нужную формулу через поиск — вводим в соответствующее окно «суммесли», выбираем оператор в списке, кликаем «Ок».

    • Появится окно, где необходимо заполнить аргументы функции.

    • Вводим аргументы — первое поле «Диапазон» определяет, какие ячейки нужно проверить. В данном случае — должности работников. Кликаем мышкой в поле «Диапазон» и указываем там D4:D18. Можно поступить еще проще — просто выделить нужные ячейки.

    • В поле «Критерий» вводим «продавец». В «Диапазоне_суммирования» пишем ячейки с зарплатой сотрудников (вручную либо выделив их мышкой). Далее — «Ок».

    • Смотрим на результат — общая заработная плата всех продавцов посчитана.

    Совет: сделать диаграмму в Excel просто и быстро — нужно всего лишь найти соответствующую кнопку на вкладке «Вставка» в меню.

    Функция СУММЕСЛИМН

    Данный оператор в Excel предназначен для вычисления суммы с использованием нескольких условий. К примеру, нужно определить заработную плату менеджеров, работающих в Южном филиале:

    • Добавляем строку с общей зарплатой менеджеров Южного филиала. Выделим ячейку, где будет показываться итог вычислений.

    • Кликаем по значку функции. В появившемся окне в поле поиска вводим «суммеслимн», нажимаем «Найти» и выбираем нужный оператор из списка.

    • В открывшемся окне необходимо заполнить аргументы функции. В «Диапазон_суммирования» указываем ячейки с заработной платой. «Диапазон_условия1» — ячейки с должностями сотрудников. «Условие1» = «менеджер», так как мы суммируем зарплату менеджеров. Теперь нужно учесть второе условие — взять менеджеров из Южного филиала. В «Диапазон_условия2» вводим ячейки с филиалами, «Условие2» = «Южный». Все аргументы определены, нажимаем «Ок».

    • В результате будет рассчитана общая зарплата всех менеджеров, работающих в Южном филиале.

    Функция СЧЁТЕСЛИ

    Данный оператор используется в Экселе, когда нужно посчитать количество ячеек, попадающих под определенное условие. Предположим, требуется узнать, сколько продавцов работает в компании:

    • Добавляем строку с количеством продавцов и выделяем ячейку, куда планируется вывести результат.

    • Кликаем по кнопке «Вставить функцию», расположенной во вкладке «Формулы» в меню. В открывшемся окне в поле «Категория» выбираем «Полный алфавитный перечень». В списке формул находим по алфавиту СЧЁТЕСЛИ, нажимаем «Ок».

    • Заполняем аргументы функции — в поле «Диапазон» указываем ячейки с должностями, в «Критерии» пишем «продавец». Далее — «Ок».

    • В результате получаем количество продавцов, работающих в компании. Эксель просто считает ячейки, где написано «продавец».

    Функция СЧЁТЕСЛИМН

    Иногда возникают более сложные задачи — например, нужно определить, сколько продавцов работает в Северном филиале. Тогда следует воспользоваться формулой СЧЁТЕСЛИМН:

    • Добавляем строку с количеством продавцов Северного филиала и выделяем ячейку с будущим результатом.

    • Кликаем по кнопке «Вставить функцию» во вкладке «Формулы». Через алфавитный перечень находим нужную функцию и нажимаем «Ок».

    • Вводим аргументы функции: «Диапазон_условия1» — это ячейки с должностями, «Условие1» = «продавец». В «Диапазон_условия2» пишем ячейки с филиалами, «Условие2» = «Северный».

    • В итоге будет определено количество продавцов Северного филиала.

    Подводим итоги

    В Excel существует несколько функций категории ЕСЛИ — использовать их нетрудно, так как программа максимально подсказывает алгоритм действий. Формулы существенно облегчают вычисления, на которые без Экселя можно потратить уйму времени и сил. К тому же нивелируется риск ошибок и человеческий фактор. Если возникают сложности с применением операторов, то, скорее всего, дело в неправильном вводе аргументов функции — перепроверьте формулу. Чтобы уточнить синтаксис, лучше воспользоваться справкой, которая в Экселе есть по каждой функции.

    Читать еще:  Как вставить рамку в word 2020

    Функция ЕСЛИ() в EXCEL

    Функция ЕСЛИ() относится к наиболее часто используемым функциям.

    Синтаксис функции

    ЕСЛИ(лог_выражение;значение_если_истина;[значение_если_ложь])

    Лог_выражение — любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ. =ЕСЛИ(A1>=100;»Бюджет превышен»;»ОК!») Т.е. если в ячейке A1 содержится значение большее или равное 100, то формула вернет ОК!, а если нет, то Бюджет превышен .

    В качестве аргументов функции, могут участвовать формулы, например: =ЕСЛИ(A1>100;СУММ(B1:B10);СУММ(C1:C10)) Т.е. если в ячейке A1 содержится значение >100, то суммирование ведется по столбцу B , а если меньше, то по столбцу С .

    Вложенные ЕСЛИ

    В EXCEL 2007 в качестве значений аргументов значение_если_истина и значение_если_ложь можно для построения более сложных проверок использовать до 64 вложенных друг в друга функций ЕСЛИ() . =ЕСЛИ(A1>=100;»Бюджет превышен»;ЕСЛИ(A1>=90;»Крупный проект»;ЕСЛИ(A1>=50;»Средний проект»;»Малый проект «)))

    Вышеуказанную формулу можно усложнять и дальше, но есть другие подходы:

    Для функции ВПР() необходимо создать в диапазоне A3:B6 таблицу значений:

    Если требуется вывести разный текст в случае наличия в ячейке А1 отрицательного значения, положительного значения или 0, то можно записать следующую формулу:

    или, если требуется вместо текстовых значений вывести формулы, можно использовать ссылки на диапазон ячеек (содержащих формулы)

    =ПРОСМОТР(A24;<-1E+307;0;1E-307>;A27:A29) (см. файл примера )

    Опущен третий аргумент [значение_если_ложь]

    Третий аргумент функции не обязателен, если его опустить, то функция вернет значение ЛОЖЬ (если условие не выполнено). =ЕСЛИ(A1>100;»Бюджет превышен») Если в ячейке A1 содержится значение 1, то вышеуказанная формула вернет значение ЛОЖЬ.

    Вместо ИСТИНА или ЛОЖЬ в первом аргументе введено число

    Т.к. значение ЛОЖЬ эквивалентно 0, то формулы =ЕСЛИ(0;»Бюджет превышен»;»ОК!») или (если в ячейке A1 содержится значение 0) =ЕСЛИ(A1;»Бюджет превышен»;»ОК!») вернут ОК!

    Если в ячейке A1 находится любое другое число кроме 0, то формула вернет Бюджет превышен . Такой подход удобен, когда проверяется равенство значения нулю.

    Связь функции ЕСЛИ() с другими функциями использующие условия

    EXCEL содержит также другие функции, которые можно применять для анализа данных с использованием условий. Например, для подсчета количества вхождений чисел в диапазоне ячеек используется функция СЧЁТЕСЛИ() , а для сложения значений, удовлетворяющих определенным условиям, используется функция СУММЕСЛИ() .

    Функция ЕСЛИ() , как альтернативный вариант, может быть также использована для подсчета и сложения значений с использованием условий. Ниже приведены иллюстрирующие примеры.

    Пусть данные находятся в диапазоне A6:A11 (см. файл примера)

    Подсчитаем сумму значений, которые больше 10 с помощью функции СУММЕСЛИ() , записав =СУММЕСЛИ(A6:A11;»>10″) . Аналогичный результат (23) можно получить с помощью формулы массива =СУММ(ЕСЛИ(A6:A11>10;A6:A11)) (для ввода формулы в ячейку вместо ENTER нужно нажать CTRL+SHIFT+ENTER )

    Теперь подсчитаем количество вхождений чисел больше 10 в диапазоне ячеек A6:A11 =СЧЁТЕСЛИ(A6:A11;»>10″) . Аналогичный результат (2) можно получить с помощью формулы массива =СЧЁТ(ЕСЛИ(A6:A11>10;A6:A11))

    Теперь, когда принцип понятен, с помощью функции ЕСЛИ() можно конструировать и другие формулы с условиями. Например, нахождение минимального значения среди чисел больше 10: =МИН(ЕСЛИ(A6:A11>10;A6:A11))

    Блог Евгения Крыжановского

    Я научу вас ремонтировать свой компьютер!

    Excel: «Если» (формула). В Excel функция «Если»

    В статье речь пойдет о функции табличного редактора Excel «Если». Она связана с логическими возможностями приложения. Данную функцию можно отнести к наиболее распространенной, которая зачастую используется во время работы.

    Ключевые возможности

    В программе Excel формула «Если» позволяет различного рода задачи, которые требуют сравнить определенные значения и получить результат. Такое решение дает возможность использовать ветвящиеся алгоритмы, создавать дерево решений.

    Примеры применения

    Функция имеет вид: =ЕСЛИ (задача; истина; ложь). Первой составной частью является логическое выражение. Оно способно выступать в виде фразы или числа. Например, «10» или «без НДС». Такой параметр обязательно следует заполнить. Истина представляет собой значение, отображающееся в качестве результата, если выражение верно. Ложь представляет собой данные, которые будут выданы, когда задача неверна.

    Равенство параметров двух ячеек

    Чтобы лучше понять возможности функции «Если» в Excel, необходимо привести примеры. Поэтому дальше стоит приступить к их рассмотрению. Нужно ввести в клетку C1 значение 8. После этого в поле по адресу D1 необходимо вписать формулу вида: =ЕСЛИ(C1 , =, >, =, 3); «проходит», «нет»).

    Если рассмотреть более сложный пример, понадобится использовать «ИЛИ» либо «И». Таким образом, можно ознакомиться с применением формулы в Excel, если существует несколько условий в задании. Например: =ЕСЛИ(ИЛИ(A1=5; A1=10); 100; 0). В данном случае можно сделать вывод, когда значение в клетке А1 равно 5 или 10, программа отображает результат 100. В противном случае он составляет 0. Существует возможность применить эти операторы, чтобы найти решение более сложным задачам.

    Например, в базе требуется вычислить должников, которым требуется заплатить более 10000 рублей. Можно задать условие, что заем не погашался более полугода, то есть шести месяцев. Благодаря функции табличного редактора Excel «Если» позволяется в автоматическом режиме получить около соответствующих имен отметку «проблемный клиент». Допустим, в клетке A1 размещены данные, которые указывают на срок задолженности (месяцы). Поле B1 содержит сумму.

    В данном случае формула представлена в следующем виде: =ЕСЛИ(И(A1>=6; B1>10000); «проблемный клиент»; «»). Таким образом, если выявлен человек, соответствующий указанным условиям, программа отображает напротив его имени соответствующий комментарий. Для других участников списка эта клетка останется пустой.

    Также можно ознакомиться с примером, когда ситуация является критической. Необходимо ввести соответствующий комментарий. Как результат, формула получится следующей: =ЕСЛИ(ИЛИ(A1>=6; B1>10000); «критическая ситуация»; «»). Однако если программа определяет совпадения по одному из параметров как минимум, отображается соответствующее примечание.

    Сложные задачи

    Функция Excel «Если» применяется для того, чтобы избежать встроенных ошибок при делении на ноль. Кроме того, она используется и в некоторых других ситуациях. Первый случай обозначается, как «ДЕЛ/0». Его можно встретить достаточно часто. Обычно это происходит тогда, когда формула «A/B» требует копирования. В это же время показатель B в отдельных ячейках составляет 0. Чтобы избежать подобной ситуации, стоит использовать возможности рассматриваемого оператора. Таким образом, требуемая формула имеет следующий вид: =ЕСЛИ(B1=0; 0; A1/B1). Итак, если клетка B1 заполнена значением «ноль», редактор отобразит «0». В противном случае программа поделит показатель A1 на данные B1 и выдаст требуемый результат.

    Скидка

    Как показывает практика, зачастую возникают ситуации, которые рассматриваются далее. Потребуется рассчитать скидки, учитывая общую сумму средств, затраченных на покупку конкретного товара. Матрица, которая используется, выглядит следующим образом: менее 1000 — 0%; 1001-3000 — 3%; 3001-5000 — 5%; более 5001 — 7%. Можно ознакомиться с ситуацией, когда в Excel имеется база данных посетителей и сведения о сумме, потраченной на покупку. Далее следует рассчитать скидку для каждого клиента. Для этого понадобится применить следующее выражение: =ЕСЛИ(A1>=5001; B1*0,93; ЕСЛИ(А1>=3001; B1*0,95;..).

    Читать еще:  Как вставить шрифт в word

    Система выполняет проверку общей суммы покупок. Если она превышает значение в 5001 рублей, выполняется умножение на 93 процента цены товара. Если превышена отметка в 3001 единиц, происходит аналогичное действие, однако уже учитывается 95%.

    Запись опубликована 17.09.2015 автором katrinas11 в рубрике Программы. Отблагодари меня, поделись ссылкой с друзьями в социальных сетях:

    Использование формул Если и Сумм. Формула эксель если то

    Excel: Функция ЕСЛИ

    Функция Если является одной из самых полезных функций в Excel. Она позволяет получать разные значения ячейки в зависимости от выполнения какого-либо условия, а также находить ошибки, уникальные значения в списке, использовать многократные проверки на выполнение условий и многое другое.

    Функция Если проверяет значение логического выражения и возвращает результаты в зависимости от того, истинно оно или ложно.

    Аргументы функции Если

    Если (лог_выражение; [значение_если_истина]; [значение_если_ложь])

    1. Лог_выражение — логическое выражение

    Логические выражения используются для записи условий, в которых сравниваются числа, функции, формулы, текстовые значения. Логическое выражение может принимать одно из двух значений — Истина или Ложь.

    Например, «A10=100» — логическое выражение; если значение в ячейке A10 равно 100, это выражение принимает значение Истина, в противном случае — значение Ложь. В этом аргументе может использоваться любой оператор сравнения .

    • > больше
    • = больше или равно
    • не равно
    1. Значение_если_истина — значение, которое помещается в ячейку (возвращается), если лог_выражение соответствует значению Истина.

    Значение может быть числом, текстом, формулой или ссылкой на ячейку.

    1. Значение_если_ложь — значение, которое возвращается, если лог_выражение соответствует значению Ложь.

    Значение может быть числом, текстом, формулой или ссылкой на ячейку.

    Обязателен только первый аргумент (логическое выражение). Если опустить второй и третий аргумент, то вместо заданных нами значений будут выводиться значения «Истина» или «Ложь» в зависимости от истинности логического выражения.

    Примеры:

    Если значение в ячейке А1 больше 5, формула возвращает значение 10, в противном случае — 20:

    2. Если (А1>=3 ; «Зачет сдал» ; «Зачет не сдал»)

    Если в ячейке А1 оценка больше или равна 3, то зачет сдан, в противном случае – нет.

    3. =Если (А1=«оплачено»; В1; 0)

    Эта формула возвращает значение из ячейки В1, если ячейка А1 содержит слово «оплачено», и 0, если в ней находится любое другое значение. Совпадение между сравниваемыми текстовыми значениями должно быть точным, но без учета регистра.

    Для создания более сложных проверок в качестве аргументов можно использовать функции Если , вложенные друг в друга. В Excel версий до 2003 включительно — до 7 вложений; вExcel версии 2007 — до 64 вложений; в Excel версии 2010 — до 128 вложений.

    Как задать простое логическое условие в Excel

    В Excel существует множество различных функций, работа которых построена на проверке логических условий. Например, это функции ЕСЛИ, СЧЕТЕСЛИ, СУММЕСЛИ и т.д. Также логические условия можно задавать в обычных формулах, если необходимо получить утвердительный ответ: Да или Нет. К примеру, задавая простые логические условия, Вы можете ответить на такие вопросы:

    • 5 больше 8?
    • Содержимое ячейки A5 меньше 8?
    • А может равно 8?

    Операторы сравнения в Excel

    В Excel имеется ряд стандартных операторов, которые используются для задания простых логических условий. Все шесть возможных операторов сравнения приведены в таблице ниже:

    Как задать условие в Excel

    Операторы сравнения позволяют задавать условия, которые возвращают логические значения ИСТИНА или ЛОЖЬ. Примеры использования логических условий представлены ниже:

    =A1=B1 — Данное условие вернет ИСТИНА, если значения в ячейках A1 и B1 равны, или ЛОЖЬ в противном случае. Задавая такое условие, можно сравнивать текстовые строки без учета регистра. К примеру, сравнивая «ЯНВАРЬ» и «январь» формула возвратит ИСТИНА.

    =A1>B1 — Следующая формула возвратит ИСТИНА, если значение ячейки А1 больше, чем в B1. В противном случае формула вернет ЛОЖЬ. Такие сравнения можно задавать и при работе с текстом.

    Например, если в ячейке A1 хранится значение «Апельсин», а в B1 – «Арбуз», то формула вернет ЛОЖЬ, поскольку в алфавитном порядке «Арбуз» находится ниже, чем «Апельсин». Чем ниже, тем больше.

    =A1 B1 — Формула вернет ИСТИНА, если значения ячеек A1 и B1 не равны. В противном случае – ЛОЖЬ.

    В Excel существуют логические функции ИСТИНА() и ЛОЖЬ(), которые не имеют аргументов. Данные функции существуют в основном для обеспечения совместимости с другими электронными таблицами. Вы можете вводить значения ИСТИНА и ЛОЖЬ прямо в ячейки или формулы, не используя форму записи функции, Excel все прекрасно поймет.

    Если Вы уверены, что уже достаточно хорошо освоили эту тему, можете обратиться к статье Используем логические функции Excel для задания сложных условий, чтобы научиться задавать условия, используя различные логические функции, например И() или ИЛИ().

    Оцените качество статьи. Нам важно ваше мнение:

    Как в Excel использовать формулу Если и Сумм

    Функция «СУММ()» предназначена для суммирования значений заданного диапазона, а «ЕСЛИ()» — логическая функция, умеющая проверять некое условие, и возвращать разные значения, в зависимости от того, условие «ИСТИНА» или «ЛОЖЬ».Поскольку в вопросе фигурируют обе функции, речь видимо идет о подсчете суммы по некоторому условию. Давайте посмотрим, как это можно сделать.

    Как посчитать сумму по условию в Excel 2007

    Сделаем маленькую табличку, состоящую из списка заказов и их стоимости. Давайте подсчитаем, какова сумма, полученная от заказов, стоимость которых выше средней, и какова сумма, полученная от выполнения дешевых заказов.Как видите из введенной функции, каждое значение из диапазона «C3:C12» будет сравниваться со средним значением этого диапазона, и если это значение больше или равно среднему, то в суммирование будет подставляться оно, а если меньше, то ноль. Теперь один важный момент! Закончив вводить эту функцию, нажмите не «Enter», как обычно, а «Ctrl+Shift+Enter». Таким образом функция вводится как функция массива и в строке формул она будет заключена в фигурные скобки. В обычном режиме функция «СУММ()» с этой задачей не справится.Ну и по дешевым товарам

    Как это сделать в Excel 2003

    Функции «СУММ» и «ЕСЛИ» работают так же и в этой версии.Покоряйте Excel и до новых встреч!

    Ссылка на основную публикацию
    Adblock
    detector
    ×
    ×