Vvmebel.com

Новости с мира ПК
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Округлить значения в excel до целого

Как правильно округлить число в Excel и Google Таблицах: все способы с подробной инструкцией

К таблицам у всех нас разное отношение, кто-то их очень любит и “рисует” по каждому поводу, кто-то терпеть не может. Но всем нам иногда приходится с ними работать, поэтому полезно знать основные возможности табличного редактора и дополнительные фишки, например, закрепление строк, использование сортировки и фильтров. Такие инструменты могут здорово облегчить жизнь.

Сегодня же мы говорим о том, как округлить число в Excel, какие есть способы, для чего это нужно, и как правильно применять функции.

Способы

Под округлением каждый из нас может понимать что-то свое, поэтому давайте рассмотрим, какие варианты есть в Excel:

  1. Простое отбрасывание дробной части. Например, у нас есть число 12,3456, мы же хотим видеть только десятые и сотые доли, большая точность нас не интересует. Отбрасыванием дробной части мы получим результат 12,34. Такой способ часто используется для красоты, чтобы не перегружать таблицу и себя лишними знаками. В таком случае для решения задачи можно использовать формат ячеек.
  2. Математическое округление. В данном случае часть знаков после запятой отбрасывается, но при этом учитывается следующая цифра после значимого для нас разряда. Мы смотрим, она больше 5 или меньше. Например, у нас есть число 12,57. Мы хотим округлить его до десятых. Тогда по правилам математики мы получаем 12,6. То есть мы увеличили десятые доли на 1, потому что сотые больше 5. Если бы мы округляли 12,52, то получили бы 12,5.
  3. Округление до ближайшего большего или меньшего числа, так называемое округление “вверх” и округление “вниз” соответственно. Например, у нас есть исходные данные: 12,75, 12,31, 11,89, которые мы хотим преобразовать в целые величины. Если мы используем округление “вниз”, то получим 12, 12, 11. Если округляем в большую сторону, то получим 13, 13, 12.
  4. Округление до десятков, сотен, тысяч и так далее. Этот вариант бывает полезен, когда нам нужны приблизительные вычисления, без детализации.
  5. Округление до ближайшего четного и нечетного значения.
  6. Округление до ближайшего кратного какой-то величине числа. Например, у нас есть 124 конфеты, а в 1 коробку вмещается 13 конфет. И мы хотим понять, сколько конфет у нас разместится в коробках по 13 штук. Тогда мы будем округлять 124 до меньшего целого числа кратного 13 и получим результат 117.

Для каждого из этих случаев в Excel есть своя функция округления. Давайте научимся ими пользоваться. Но сначала посмотрим, как можно изменить внешний вид данных в таблице.

Формат ячеек

Часто нам нужно не фактическое округление, а просто аккуратный единый вид всех чисел в таблице. В таком случае мы не используем формулы, а просто меняем внешний вид данных.

Для этого выделяем ячейки в таблице и нажимаем правую кнопку мыши. В контекстном меню выбираем нужный раздел.

Во вкладке “Число” выбираем подходящий формат.

“Общий” используется по умолчанию и отображает данные в ячейках так, как они есть, изменить внешний вид тут не получится.

“Числовой” позволяет отображать столько знаков после запятой, сколько нужно, или вовсе убрать дробную часть.

“Денежный” и “Финансовый” похожи на “Числовой”, но позволяют также указывать валюту.

В “Процентном” тоже можно регулировать количество знаков после запятой. Если мы переключаемся на этот формат, то исходные данные в ячейках умножаются на 100, и добавляется значок %.

Я для своих вычислений чаще всего пользуюсь числовым форматом. Он универсальный и позволяет быстро привести ячейки к единому виду.

Этот способ подходит для Excel любого года выпуска. Если у вас новая версия программы, то решить задачу можно еще быстрее. Для этого во вкладке “Главная” есть специальный блок опций. Тут можно выбрать подходящий формат из выпадающего списка, а стрелочками влево и вправо увеличить или уменьшить количество разрядов.

Внимание: при изменении формата данных фактические значения в ячейках не меняются, они остаются прежними, просто отображаются по-другому.

Как работать с функциями в Excel

Мы рассмотрели самый простой способ убрать лишние знаки. Использовать его довольно удобно, если менять сами данные в таблице нам не нужно. Теперь мы переходим к использованию различных функций. Но сначала я хочу напомнить вам, что это такое, а также как с ними работать.

Функции ускоряют и упрощают вычисления. Например, нам надо посчитать сумму в столбце, в котором 100 значений. Мы можем делать это самым прямым способом “1+20+30+43…” и так 99 раз. Или написать встроенную команду “СУММ”, указать диапазон ячеек, и программа за секунду сделает расчеты.

Первый способ

Чтобы вручную написать формулу в ячейке с использованием функции, обязательно нужно:

  1. Поставить знак =.
  2. Правильно указать название.
  3. Открыть круглую скобку.
  4. Указать через точку с запятой аргументы, то есть данные, которые будут использоваться.
  5. Закрыть скобку.

Что может выступать аргументом математических формул:

Пример: функция “=СУММ(F21:F30)” посчитает сумму чисел, написанных в столбце F с позиции F21 до F30.

Эти правила нужно запомнить, иначе программа не сможет сделать вычисления, а будет выдавать ошибку такого вида.

Второй способ

Если неудобно писать команды вручную, то можно воспользоваться библиотекой, которая находится во вкладке “Формулы”.

Нас в данный момент интересуют математические операции. Нажимаем на соответствующий раздел и выбираем нужную процедуру.

Откроется диалоговое окно, в котором легко понять, какие аргументы нужно указать. Заполните поля и нажмите “ОК”.

Отбрасывание дробной части

Этот способ подойдет, если нам не важно, произойдет ли округление по математическим законам, и в какую сторону изменится значение. Когда мы просто хотим упростить вычисления, убрав лишние знаки, то можем отбросить их. Для этого есть функция “ОТБР”, которая содержит 2 параметра:

  • число, над которым нужно произвести действие;
  • количество знаков после запятой, которое следует оставить.

Например, у нас есть цена товара 4 716 рублей 77 копеек и еще уйма знаков после запятой. Логично отбросить все лишнее и получить только рубли и копейки.

Если же мы хотим получить только рубли без копеек, то вторым аргументом пишем не 2, а 0.

Математическое округление

Для привычного нам со школы математического действия есть специальная функция “ОКРУГЛ”. Она нужна для работы с дробными частями и целочисленными значениями. Аргументами выступают число и количество разрядов, которые нужно оставить после запятой.

Например, у нас есть значение 34,83021, и мы хотим округлить его с точностью до сотых. Тогда формула будет выглядеть так: “=ОКРУГЛ(34,83021;2)”.

Если в качестве второго аргумента указать 0, то получим целочисленное значение, то есть округлим первоначальные данные до единиц. А если количество разрядов будет отрицательным, то преобразовываться будет уже целое число.

Например, мы хотим округлить до сотен 1245,329. Тогда делаем такую запись в ячейке нашей таблицы: “=ОКРУГЛ(1245,329;-2)” и получаем результат 1 200.

В меньшую и большую сторону

Бывает так, что нам не нужно точное математическое вычисление, а важно не преувеличить или, наоборот, не уменьшить значение в ячейке. Тогда мы будем округлять в меньшую или большую сторону.

Читать еще:  Вычислить процент от числа в excel

До дробных частей

Чтобы округлить в меньшую или большую сторону, есть универсальные функции “ОКРУГЛВНИЗ” и “ОКРУГЛВВЕРХ”. Они позволяют делать преобразования с точностью до целых и дробных частей.

Первый аргумент – это число, которое требуется округлить. Второй – количество разрядов. Если он больше 0, то показывает, сколько знаков после запятой должно остаться, если меньше 0, то происходит округление до десятков, сотен, тысяч. Если аргумент равен 0, то мы получаем точность до единиц, дробная часть отбрасывается.

Давайте посмотрим на примере работу этих двух команд.

До целых

Есть еще один способ округлить в меньшую или большую сторону. Для этого нам понадобятся функции “ОКРВНИЗ” и “ОКРВВЕРХ”. Они применяются для получения целочисленного результата.

Второй аргумент показывает, до какого разряда мы округляем:

  • 10 – до десятков;
  • 100 – до сотен;
  • 1 000 – до тысяч и т. д.

Показываю на примере.

Округление “вниз” до единиц можно заменить функцией “ЦЕЛОЕ”, у которой есть единственный аргумент – число. Результат будет таким же, как при использовании “ОКРВНИЗ”.

Округлить в большую сторону до ближайшего четного или нечетного целого значения помогают действия “ЧЁТН” и “НЕЧЁТ”. Пример использования одного из них вы видите на скриншоте.

До целых с учетом кратности

Помните пример с конфетами, который был в начале статьи? Сейчас мы научимся округлять до ближайшего кратного какой-то величине значения. Для этого служат 2 функции: “ОКРВНИЗ.МАТ” и “ОКРВВЕРХ.МАТ”. Первая уменьшает исходную величину, а вторая соответственно увеличивает.

Например, у нас есть число 124, и мы хотим округлить его до ближайшего большего кратного 5 значения. Тогда пишем в ячейке: “=ОКРВВЕРХ.МАТ(124;5)” и в результате получаем 125.

В Google Таблицах

Если вы любите работать в режиме онлайн, то можете задать формулу для округления данных в Google Таблицах.

Чтобы изменить формат ячеек, используйте опцию на основной панели инструментов.

Для уменьшения или увеличения разрядности также есть соответствующий инструмент.

Чтобы открыть перечень встроенных формул, нажмите на маленький черный треугольник рядом со значком суммы.

Чтобы округлить данные в ячейках, наводим курсор на математические функции и выбираем один из вариантов:

Работают они точно так же, как в Excel, но в Google Таблицах нет действий “ОКРВНИЗ.МАТ” и “ОКРВВЕРХ.МАТ”. Вместо них можно использовать “ОКРУГЛТ”, эта функция округляет до ближайшей кратной определенному числу величины. То есть в данном случае программа сама решает, в большую или меньшую сторону изменятся исходные данные.

Заключение

Мы рассмотрели все основные способы округления чисел в Microsoft Excel и Google Таблицах. Конечно, есть много частных случаев, которые требуют нетривиального решения. Если вы столкнулись с ситуацией, которая не описана в этой статье, напишите комментарий, и я постараюсь помочь и подсказать, как правильно составить формулу.

Округление в Excel. Пошаговая инструкция

Округление чисел в Excel нужно для удобного форматирования, прогнозирования и коммуникации.

Существует множество способов округления, такие как округление до целого числа, округление в большую сторону, округление в меньшую сторону и т.д. В Excel мы можем округлять числа с помощью функций. Их мы и рассмотрим в этой статье.

Округление чисел в Excel с помощью изменения формата ячейки

Если вы хотите округлить числа исключительно с целью презентации, вы можете изменить формат ячейки, выполнив следующие шаги:

  • Кликнуть по ячейке с числовым значением;
  • Открыть меню форматирования ячейки с помощью сочетания клавиш CTRL+1 или кликнуть по ячейке правой кнопкой и в выпадающем списке выбрать пункт “ Формат ячеек “;
  • В всплывающем окне “ Формат ячеек ” перейти на вкладку “ Число “;
  • В разделе “ Числовые форматы ” кликнуть по пункту “ Числовой “;
  • В меню окна найти пункт “ Число десятичных знаков ” и указать точное количество знаков после запятой, которое вы хотите оставить;
  • Кликните по кнопке “ ОК ” для сохранения настроек форматирования.

Важно! Этот метод только визуально округляет число, не “отрезая” числа после запятой.

Округление в Excel с помощью функции ОКРУГЛ

Функция ОКРУГЛ часто используется в Excel для округления чисел. С ее помощью вы можете задать количество чисел после запятой.

Синтаксис

=ОКРУГЛ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Основы использования функции

  • если аргумент число_разрядовбольше “0”, то число округляется до указанного количества десятичных знаков. Например, =ОКРУГЛ(500,51;1) вернет “500.5”;
  • если аргумент число_разрядов равен “0”, то число округляется до ближайшего целого числа. Например, =ОКРУГЛ(500,51;0) вернет “501”;
  • если аргумент число_разрядовменьше “0”, то число округляется влево от десятичного значения. Например, =ОКРУГЛ(500,51;-1) вернет “501”.

Функция ОКРУГЛ работает на основе математического правила, по которому она определяет в большую или меньшую сторону следует округлить число:

  • Если число после запятой равно от 0 до 4, то округление будет произведено в меньшую сторону;
  • Если число после запятой равно от 5 до 9, то функция округлит в большую сторону.

На скриншоте ниже показаны примеры использования функции:

Округление в Excel в большую сторону с помощью функции ОКРУГЛВВЕРХ

Функция ОКРУГЛВВЕРХ округляет число в большую сторону, вне зависимости от того, какое число стоит после запятой.

Синтаксис

=ОКРУГЛВВЕРХ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Примеры использования функции ниже:

Округление в Excel в меньшую сторону с помощью функции ОКРУГЛВНИЗ

Функция ОКРУГЛВНИЗ округляет число в меньшую сторону, вне зависимости от того, какое число стоит после запятой.

Синтаксис

=ОКРУГЛВВНИЗ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

На скриншоте ниже примеры использования функции:

Формулы excel и как правильно округлить до целых

Программа Excel для работы с электронными таблицами помогает не только создавать таблицы и диаграммы с помощью формулы excel и как правильно округлить до целых, но и может выполнять много вычислений за вас. Потому что с помощью функций и формул можно выполнять сложные вычисления — если вы знаете, как это работает. Мы объясним, как правильно использовать формулу Excel функцию ОКРУГЛИТЬ до целых.

Функция округления Excel

Excel предлагает вам несколько функций, с которыми вы можете округлить. Но давайте начнем с самого простого варианта: функция ОКРУГЛИТЬ. Их применение относительно просто: вы сначала вводите округляемое число. Вторым аргументом в формуле ОКРУГЛИТЬ является число, указывающее, сколько цифр Excel должно округлять до значения.

Числовой аргумент относится к значению, которое вы хотите округлить. Поэтому вы можете либо ввести число непосредственно в формулу, либо указать ссылку на другую ячейку.

Читать еще:  Число прописью в excel формула

Вы используете параметр «Количество_Цифр», чтобы указать, с какой позиции вы хотите округлить. Введите положительные десятичные разряды с положительными значениями. Соответственно, значение 0 не будет иметь десятичных разрядов и, следовательно, генерирует целое число. Если вы используете отрицательные значения, цифры слева от запятой округляются в большую или меньшую сторону до ближайшего десятичного знака.

Вы можете использовать ОКРУГЛИТЬ либо с помощью функции «Вставить функцию ()», либо ввести функцию непосредственно на панели инструментов. При использовании последнего метода вы должны помнить, что функция должна начинаться со знака равенства (=), в противном случае Excel воспринимает вводимые данные как текст для отображения.
С помощью простой функции в Excel вы можете установить, как именно округлять.

Вам не нужно использовать собственную ячейку для округления значения. Excel также позволяет вкладывать функции. Таким образом, вы можете объединить функцию ОКРУГЛИТЬ напрямую с другой формулой.

В этом примере вы создаете среднее из различных чисел и округляете результат. Тогда в ячейке появляется только округленное значение.

ОКРУГЛИТЬ: более сложная формула округления

Вы можете использовать функцию VRUNDEN для округления значения до соответствующего кратного другого числа. Как и в случае с обычной функцией ОКРУГЛИТЬ, вы сначала вводите значение в формулу, которое должно быть округлено. С помощью этого метода вы также можете либо ввести значение напрямую, сослаться на ячейку или поставить на ее место другую функцию. Второй аргумент — это значение, которое должно быть округлено до кратного.

Например, если вы хотите отображать результаты только с шагом 25, вы можете использовать функцию ОКРУГЛИТЬ. Расстояние до кратно решает, округлять ли вверх или вниз. Excel всегда выберет кратчайшее расстояние. Если расстояние одинаково в обоих направлениях, число округляется в большую сторону.

Вы также можете работать с функцией ОКРУГЛИТЬ, если вы всегда хотите округлить минуты вверх или вниз до ближайшего часа.

Вы можете выполнять более сложные задачи округления в Excel с помощью функции ОКРУГЛИТЬ.

Простое округление: четное и нечетное

Вы можете использовать два очень простых метода округления для округления до следующего четного или нечетного целого числа. Неважно, хотите ли вы округлить число с десятичными знаками или без них. В качестве аргумента в синтаксисе указывается только округляемое число.

В случае положительных чисел число округляется в большую сторону (3 становится 4); отрицательные числа всегда округляются вниз (-1 становится -2).

Настроить отображение: только поверхностно округлить в Excel

Вы также можете отформатировать ячейки в Excel для отображения только определенного количества десятичных знаков. При щелчке правой кнопкой мыши в соответствующем месте появляется контекстное меню, в котором вы выбираете « Форматировать ячейки . ». На вкладке « Числа» и категории « Числа» у вас есть возможность указать желаемое количество десятичных знаков. Например, если вы введете 0, отображаются только целые числа. Отличие от функции ОКРУГЛИТЬ заключается в том, что округление путем форматирования влияет только на отображение. Вы увидите округленное число на своем рабочем листе, но правильное значение, включая десятичные разряды, сохраняется на фоне ячейки.

Разницу можно увидеть не позднее, когда вы продолжите вычисления с числами: если вы сохранили значения 2,4, 2,3 и 3,3 в отформатированных ячейках без десятичных разрядов, вы увидите только 2, 2 и 3. Теперь создайте В Excel 8 будет отображаться сумма этих значений, поскольку программа по-прежнему учитывает десятичные разряды. Если бы вы работали с функцией ОКРУГЛИТЬ, результат был бы 7.

Если вы отформатируете ячейку в Excel, вы можете по крайней мере округлить отображение значения.

Как округлить число в экселе до целого, десятых или сотых в большую и меньшую сторону

Всем привет, мои дорогие друзья и гости блога. Давно мы с вами не ковыряли знаменитый табличный редактор от Microsoft, поэтому я решил исправить эту несправедливость. Конкретно, мы с вами сегодня узнаем, как в экселе округлить число до целого в большую или меньшую сторону. Кроме того, мы сможем сделать округление, например до 2 знаков после запятой, чтобы было удобнее считать и отбросить ненужные «хвосты», как в случае с числом ПИ. Многие не воспринимают эту фишку всерьез, но тем не менее я считаю, что она очень важна.

Уменьшение разрядности

Если вам не нужно постоянно производить округление чисел, то лучше всего нам подойдет функция «Уменьшить разрядность» . Далеко ходить не нужно, так как данная кнопка находится прямо в ленте во вкладке «Главная» . Сама же кнопка представляет собой один и два нуля со стрелкой вправо. Нажав на нее уменьшится 1 знак после запятой с конца, и автоматом округлится предыдущий в большую или меньшую сторону.

Давайте рассмотрим на простом примере. Допустим, у меня есть число 5,7777. Нажав один раз на вышеуказаную кнопку мы увидим, что знаков после запятой стало меньше, и оно округлилось, то есть стало 5,778. При еще одном нажатии цифра станет 5,78.

Ну а еще пару кликов спустя мы получим округленную цифру 6. А если бы само число было представлено как 5,49, то эксель округлил бы нам его до пятерки.

Формат ячеек

К данному способу стоит приходить, если вы хотите округлять цифры к конкретных столбцах, строчках или диапазоне ячеек. Для этого нужно сделать всего пару простых действий.

  1. Выделям нужный диапазон, и нажав правой кнопкуой мыши выбираем пункт «Формат ячеек» .
  2. Далее, ищем пункт «Числовой» и меняем значение в блоке «Число десятичных знаков» вместо 2 (по умолчанию) на ноль.

Теперь, если вы напишите какое-либо нецелое число, то программа автоматически его округлит в данном диапазоне. Например, даже если я напишу 1,5, то Excel автоматом вставит 2, хотя формально там все равно будет находится наше реальное значение.

  • Во-первых, реальное значение будет написано в строке для формул вверху;
  • Во-вторых, если я суммирую по формуле два этих числа (2+2), то нам выдаст 3, а не 4. А все потому, что цифры округленные, и система продолжает считать их как 1,5, а не 2. Но на первый взгляд кажется, что Эксель сошел с ума, раз он думает, что 2+2 будет 3.

Так что. рекомендую иметь данный способ ввиду.

Как сделать округление в excel с помощью функции?

Ну и конечно же, знаменитый табличный редактор славится своими формулами и функциями. Поэтому и не стоит удивляться, что и с помощью них мы сможем округлить числа в excel. Причем таких функций там несколько, на все случаи жизни. Поэтому, предлагаю их разбить на несколько блоков.

По количеству знаков

Сперва предлагают начать с классического округления. Для этого в одной ячейке запишем, например 6,7836. И вот теперь приступим к самому интересному.

  1. Нажмите на любую пустую ячейку, где мы хотим получить результат, после чего жмем на значок вставки функции.
  2. В появившемся окне впишите ОКРУГЛ. У вас появится три доступных варианта. ОКРУГЛ — это классическая функция, которая будет округлять цифры как полагается (например, 5,49 до 5, а 5,51 до 6). А функции ОКРУГЛВВЕРХ и ОКРУГЛВНИЗ будут принудительно тянуться в меньшую или большую сторону. Причем, если вы выберите ОКРУГЛВВЕРХ, когда у вас стоит число 5,2, то функция всеравно сделает округление до шестерки, так как вы принудительно задали ей двигаться только в большую сторону.
  3. После того, как мы выбрали функцию ОКРУГЛ, намимаем ОК. А дальше нам предстоит выбрать то самое число, которое мы написали в начале. А в строку «Число разрядов» обязательно впишите количество знаков после запятой, до которого будет сделано округление. Если вы хотите, чтобы оно стало целым без запятой, то напишите 0 (ноль), а если вам необходимо, чтобы округление происходило до сотых, то смело ставьте двойку, после чего нажмите ОК. Но в данном примере я вообще хочу обойтись без каких-либо десятых или сотых, поэтому ставлю ноль.
Читать еще:  Нумерация строк в excel по порядку

Теперь в данной ячейке будет стоять уже готовая цифра, а именно семерка.

По кратности

Данная функция рассчитана на то, чтобы округлять любые числа, которые кратны нужной вам цифре. Причем неважно, десятичное оно или целое. Допустим, у нас есть число 19. И теперь нам нужно найти то, значение, которое кратно допустим трем. Для этого делаем следующее:

  1. В отдельную ячейку записываем 19, после чего жмем на вызов функции.
  2. Далее, пишем в поиске вбиваем ОКРУГЛТ и жмем ОК.
  3. После того как нам откроется форма, нужно будет выбрать значение 19, которое мы записали ранее. А во вторую строчку написать то число, кратное которому и должно быть наше 19. Ранее мы решили, что это будет тройка, поэтому ее и вписываем, после чего жмем ОК.

Как видим, теперь в нашей ячейке красуется 18, так как оно ближайшее из тех, которые кратны трем. Надеюсь, что суть данной функции ясна.

Все эти штуки можно проделать как с единичными значениями, так и с целыми столбцами или строками. Достаточно выделить диапазон ячеек, зажав левую кнопку мыши и проведя в нужном направлении.

Надеюсь, что статья вам понравилась, а представленные способы оказались для вас полезными. Поэтому, обязательно подписывайтесь на паблик в ВК и на мой канал на Ютубе. Ну и и конечно же не забывайте заходить на мой блог без каких-либо напоминаний. Я всегда стараюсь выложить для вас что-нибудь полезное, актуальное и интересное. Удачи вам. Пока-пока!

Microsoft Excel

трюки • приёмы • решения

Как в Excel округлять значения

Округление чисел — распространенная задача, и Excel предоставляет достаточно функций, которые округляют значения разными путями (табл. 111.1). Вы должны понимать разницу между округлением и форматированием значения.

Когда вы форматируете число так, чтобы оно отображало определенное количество знаков после запятой, формулы, которые ссылаются на это число, работают с его фактическим значением, которое может отличаться от отображаемого. Когда вы округляете числа, то формулы, которые ссылаются на эти значения, используют округленные числа.

Таблица 111.1. Функции округления Excel

В следующих разделах приведены примеры формул, которые используют различные типы округления.

Округление до ближайшего кратного числа

Функция ОКРУГЛТ полезна для округления значений до ближайших кратных. Например, вы можете использовать ее, чтобы округлить число до ближайшего, кратного 5. Следующая формула возвращает 135: =ОКРУГЛТ(133;5) .

Округление денежных значений

Часто приходится округлять валютные значения. Например, рассчитанная цена может оказаться равной 45,78923 р. В таком случае вы захотите округлить ее до ближайшей копейки. Этот процесс может показаться простым, но для округления значений такого типа вам предлагается на выбор один из трех следующих способов:

  • в большую сторону до ближайшей копейки;
  • в меньшую сторону до ближайшей копейки;
  • до ближайшей копейки (округление может быть или в большую, или в меньшую сторону).

Следующая формула предполагает, что значение рублей и копеек содержится в ячейке А1. Формула округляет значение до ближайшей копейки. Например, если ячейка А1 содержит 12,421 р., формула возвращает 12,42 р.: =ОКРУГЛ(А1;2) .

Если вам необходимо округлить значение в большую сторону до ближайшей копейки, используйте функцию ОКРВВЕРХ. Следующая формула, например, округляет значение в ячейке А1 до ближайшей копейки (если ячейка А1 содержит значение 12.421 р., формула возвращает 12,43 р.): =ОКРВВЕРХ(А1;0,01) .

Чтобы округлить рублевое значение в меньшую сторону, используйте функцию ОКРВНИЗ. Следующая формула, например, округляет такое значение в ячейке А1 в меньшую сторону до ближайшей копейки (если ячейка А1 содержит 12.421 р., то формула возвращает 12.42 р.): =ОКРВНИЗ(А1;0,01) .

Чтобы округлить рублевое значение до пяти копеек, используйте эту формулу: =ОКРВВЕРХ(А1;0,05) .

Использование функций ЦЕЛОЕ и ОТБР

На первый взгляд, функции ЦЕЛОЕ и ОТБР могут показаться похожими. Они обе преобразовывают значение в целое число. Функция ОТБР просто удаляет дробную часть числа. Функция ЦЕЛОЕ округляет в меньшую сторону до ближайшего целого числа, основываясь на значении дробной части числа.

На практике ЦЕЛОЕ и ОТБР возвращают разные значения только при использовании отрицательных чисел. Например, эта формула возвращает -14.0: =ОТБР(-14,2) .

Следующая формула возвращает -15,0, поскольку число -14,2 округляется в меньшую сторону до следующего целого числа: =ЦЕЛОЕ(-14,2) .

Функция ОТБР принимает дополнительный (необязательный) аргумент, который может быть полезен для усечения десятичных значений. Например, следующая формула возвращает 54,33 (значение усекается до двух десятичных знаков): =ОТБР(54.3333333;2) .

Округление до N значащих цифр

В некоторых ситуациях может понадобиться округлить значение до определенного количества значащих цифр. Например, вы хотите выразить число 1432,187 в терминах двух значащих цифр (то есть как 1400,000). Число 84 356 выражается в трех значимых цифрах как 84 300.

Если значение является положительным числом без десятичных знаков, то вам поможет следующая формула. Она округляет число в ячейке А1 до двух значащих цифр. Для округления до различного количества значащих цифр замените 2 в этой формуле нужным вам числом: =ОКРУГЛВНИЗ(А1;2-ДЛСТР(А1)) .

Для нецелых и отрицательных чисел решение будет немного более сложным. Следующая формула предлагает более общее решение, округляющее значение в ячейке А1 до количества значащих цифр, указанного в ячейке А2. Эта формула работает для положительных и отрицательных целых и нецелых чисел: =ОКРУГЛ(Al;А2-1-ЦЕЛОЕ(LOG10(ABS(А1)))) .

Например, если ячейка А1 содержит число 1,27845, а в ячейке А2 хранится 3, то формула вернет 1,28000 (значение, округленное до трех значащих цифр).

В ремонт металлических дверей замков входит починка дверных петель, коробок и полотен, которые с течением времени и из-за неправильного использования могут расклеиваться и перекашиваться. Бывает так, что они просто перестают плотно держаться в массиве, потому что их плохо прижимают шурупы, которые, в свою очередь, могут выходить из массива вследствие плохо нарезанной резьбы или сырой древесины, куда они были вкручены. В результате после усыхания материала отверстия стали шире и шурупы вышли из них.

Ссылка на основную публикацию
Adblock
detector